Kubuntu 4.11: prima impressione… sconvolgente!

Quando il LiveCD di Kubuntu 4.11 si è bloccato per la terza volta sul mio vecchio ma glorioso Toshiba Qosmio G20 confesso che ero scoraggiato. Ho scaricato l’Alternate CD senza troppo entusiasmo: della serie “proviamo” anche quella. Parto con l’installazione preparandomi ad impazzire per sistemare le partizioni dei due dischi fissi, ricordandomi che secoli fa per installare Linux avevo dovuto farlo sul disco secondario switchando il boot drive a mano dal BIOS. Lancio l’installazione testuale, seleziono la lingua e procedo fino al partizionamento. Sorpresa avevo riservato lo spazio per Linux (root+swap) e non me ne ricordavo. Un segno del destino? Configuro manualmente per utilizzare la root in ext4 e lo swap, confermo e lascio andare. Dopo un paio d’ore mi ricordo che l’installazione è in corso e vado a vedere: siamo alle scelte relative a GRUB, il boot loader. Mi chiede se installarlo sull’MBR: domanda difficile. Sono tentato, ma se mi sovrascrive il boot loader attuale (SBM) e non funziona so già che impazzirò per poter avviare di nuovo le due installazioni di Windows indipendenti. Vabbé, proviamo; se va male ci sono le copie. Un paio di invii e il CD viene espulso. Riavvio e mi preparo al peggio. Sorpresa: funziona tutto! Guardandoci meglio non proprio tutto, ma sono comunque impressionato; funzionano anche la rotella del volume, le combinazioni con il tasto Fn ed il touchpad. Unica pecca rilevante: la tastiera è settata in americano e non c’è verso di farle cambiare idea. Pazienza, ci studierò su. Primo todo: sistemare GRUB; vede tutte le installazioni ma Windows non si avvia (nessuno dei due, a dire il vero). Credo che sia solo un problema di partizioni attive e nascoste. Stay tuned.

Funziona:

  • touchpad
  • rotella volume
  • combinazioni con tasto Fn (mute, ecc.)
  • rete wired
  • audio
  • tastiera e mouse aggiuntivi con adattatore USB-PS2 (!)

Non funziona:

  • tastiera settata con mappatura US invece che IT (@ sopra il 2, accentate non funzionanti, ecc.) RISOLTO -link-
  • avvio di Windows da GRUB (dual boot o meglio trial boot) RISOLTO -link-
  • le due partizioni Windows non sono montate automaticamente (erano nascoste all’installazione) RISOLTO -link-
  • il secondo hard disk non contiene partizioni riconosciute come valide (ce ne sono due invece)
  • montaggio automatico chiavette USB

Da verificare:

  • rete wireless

© Daniele Lolli (UncleDan) 2018. All rights reserved.

Powered by Hydejack v8.1.1